Getting Started w/ LilyPad Arduino on Mac OS X

This document explains how to connect your LilyPad Arduino board to a computer and upload your first sketch.

1 | Get a LilyPad Arduino, FTDI board, and USB cable.

In this tutorial, we assume you're using a LilyPad Arduino Main Board, Simple Board, or SimpleSnap. This tutorial will also work for the LilyPad Arduino Protosnap boards: the ProtoSnap LilyPad Development Board and the Protosnap LilyPad Simple Board. If you have a LilyPad Arduino USB, read the corresponding page in the getting started guide for setup instructions.

You'll also need a standard mini USB cable and an FTDI board.

2 | Download the Arduino environment

Get the latest version from the download page.

When the download is finished, double click the .zip fle. This will expand the Arduino application.

3 | Install the Arduino Software

Copy the Arduino application into your Applications folder.

4 | Install the FTDI Drivers

You will need to install the drivers for the FTDI board that enables you to program the LilyPad Arduino. You need to download the latest version of the drivers from the FTDI website.

Scroll down to the middle of this page, where there is a table listing drivers for different computers. Click on the most recent driver that is compatible with your computer. If your computer is running OS 10.5 or higher you should use the x64 (64-bit) drivers. If you're running OS 10.4 you should use the x32 (32-bit) drivers. Otherwise, you should use the PPC (PowerPC) drivers. To determine which OS your computer has, click on the apple icon in the upper right hand corner of your screen and click on "About This Mac" menu item.

For more detailed installation instructions, see the guides on the FTDI website

Once downloaded, double click the package, and follow the instructions in the installer. You'll need to restart your computer after installing the drivers.

5 | Connect the board

Attach the FTDI board to your LilyPad Arduino board. Attach one end of the USB cable to your FTDI board and the other end to a USB port on your computer.

6 | Launch the Arduino application

Browse to your Applications folder and double-click the Arduino application to open the software. (Note: if the Arduino software loads in the wrong language, you can change it in the preferences dialog. See the environment page for details.)

7 | Open the blink example

Open the LED blink example sketch: File > Examples > 1.Basics > Blink.

8 | Select your board

You'll need to select the entry in the Tools > Board menu that corresponds to your LilyPad Arduino. If your board was purchased in 2012 or later, you should select "LilyPad Arduino w/ ATmega328 from this menu".

9 | Select your serial port

Select the correct serial port from the Tools > Serial Port menu. This tells the Arduino software which USB port your LilyPad Arduino is attached to. On the Mac, this should be something with /dev/tty.usbserial in its name.

10 | Upload the program

Now, click the "Upload" button in the environment. Wait a few seconds - you should see the RX and TX leds on the FTDI board flashing. If the upload is successful, the message "Done uploading." will appear in the status bar.

A few seconds after the upload finishes, you should see the LED on the board start to blink (in green). If it does, congratulations! You've gotten your LilyPad Arduino up-and-running.

If you have problems, see the troubleshooting suggestions.

11 | Additional Resources

The text of the Arduino getting started guide is licensed under a Creative Commons Attribution-ShareAlike 3.0 License. Code samples in the guide are released into the public domain. The text of the Arduino getting started guide is licensed under a Creative Commons Attribution-ShareAlike 3.0 License. Code samples in the guide are released into the public domain.

Share