Entorno de desarrollo Arduino

El entorno de desarrollo Arduino contiene un editor de texto para escribir código, un área de mensajes, una consola de texto, una barra de herramientas con botones para las funciones más comunes, y una serie de menúes. Se conecta al hardware de Arduino para cargar programas y comunicarse con ellos.

Los programas de software escritos usando Arduino se denominan sketches. Estos sketches se escriben en el editor de texto. Éste tiene características para cortar/pegar y para la buscar/sustituir texto. El área de mensajes muestra lo que ocurre mientras se está grabando y exportando un sketch y también muestra errores. La consola muestra la salida de texto del entorno Arduino incluidos todos los mensajes de error y otra información. Los botones de la barra de herramientas te permiten comprobar y cargar programas, crear, abrir y guardar sketches y abrir el monitor serie:

Verificar/Compilar
Comprueba los errores en el código de tu sketch.

Detener
Detiene el monitor serie, o deshabilita la acción de otros botones.

Nuevo
Crea un nuevo sketch.

Abrir
Muestra un menú con todos los sketches de tu biblioteca de sketches (sketchbook). Elige uno con el ratón y se abrirá en la ventana actual.

Nota: Debido a un problema en Java, no puedes desplazarte por este menu; si necesitas abrir un sketch de los últimos de la lista, mejor utiliza el menú File | Sketchbook.

Guardar
Graba tu sketch.

Grabar la placa E/S
Compila tu código y lo graba en la placa de E/S Arduino. Ver grabación para más detalles.

Monitor Serie
Abre el monitor serie.

Hay muchos más comandos dentro de los cincos menús: File, Edit, Sketch, Tools, Help. Los menús son sensibles al contexto, lo que significa que sólo estarán disponibles las opciones de menú significativas para la tarea que estés realizando.

Edit

  • Copy for Discourse
    Copia el código de tu sketch en el portapapeles con el formato adecuado y sintaxis coloreada para ser publicado en el foro.

  • Copy as HTML
    Copia el código de tu sketch en el portapapeles con el formato HTML para incluirlo en páginas web.

Sketch

  • Verify/Compile
    Comprueba los errores en el código de tu sketch.

  • Import Library
    Añade una Adds a biblioteca a tu sketch insertando órdenes #include en el código de tu código. Para más detalles, ver libraries más abajo.

  • Show Sketch Folder
    Abre la carpeta del sketch en el escritorio.

  • Add File...
    Añade un archivo de código fuente al sketch (Será copiado desde su ubicación actual). El nuevo archivo aparece en una nueva pestaña en la ventana del sketch. Los archivos los puedes eliminar del sketch utilizando el menu tab.

Tools

  • Auto Format
    Esto formatea tu código correctamente: Por ejemplo, i.e. realiza una sangría en el texto del código de manera que las llaves de apertura y cierre estén alineadas y que las órdenes o instrucciones estén dentro de estas llaves y con más sangría.

  • Board
    Selecciona la placa que quieres usar. Lée más abajo las descripciones de varias placas.

  • Serial Port
    Este menú contiene todos los dispositivos serie (reales o virtuales) de tu ordenador. Se debe actualizar automáticamente cada vez que abres el menú Tools.

  • Burn Bootloader
    Las opciones de este menú te permiten grabar un gestor de arranque (bootloader) en el microcontrolador de una placa Arduino. Esto no lo necesitas habitualmente para usar una placa Arduino pero es muy útil si te compras un microcontrolador ATmega nuevo (que normalmente viene sin gestor de arranque). Asegúrate de que has seleccionado la placa correcta en el menú Boards antes de grabar el gestor de arranque. Al utilizar un ISP AVR, tendrás que seleccionar la opción de menú correspondiente a tu programador del menú Serial Port.

Cuaderno de sketch o Sketchbook

El entorno de desarrollo de Arduino incluye el concepto de sketchbook o cuaderno de sketches: un lugar estándar donde almacenar tus programas (o sketches). Los sketches de tu cuaderno de sketches puedes abrirlos desde el menú File > Sketchbook o desde el botón Open de la barra de herramientas. La primera vez que ejecutas el software de Arduino, automáticamente te creará una carpeta para tu cuaderno de sketches. Puedes ver o cambiar la ubicación de tu cuaderno de sketches desde la ventana de diálogo Preferences.

Tabs, Múltiples archivos, y Compilación

Un sketch puede componerse de varios archivos (tabs). Para manegarlos, click on the right-facing arrow just above the scroll bar near the top of the environment. Las Tabs tiene una de éstas cuatro extensiones: sin extensión, .c, .cpp, o .h (si tu das cualquier otra extensión, el símbolo del punto ('.') se convertirá en un símbolo de subrayado ('_'). Las Tabs sin extensión son tratadas igual que un archivo con código fuente escrito en lenguaje C++. Aquellos, archivos del sketch con extensión .c o .cpp, son enlazados siempre cuando compiles (verifiques) el sketch o lo prepares para grabarlo en el microcontrolador. Cualquier archivo .h (archivos de cabecera) en el sketch debes incluirlo explícitamente con el comando de preprocesador #included.

Grabar un sketch en el microcontrolador.

Antes de grabar tu sketch en el microcontrolador, necesitas seleccionar los elementos correctos de los menúes Tools > Board y Tools > Serial Port. Las placas están descritas más abajo. En los Mac, el puerto serie generalmente es algo así como /dev/tty.usbserial-1B1 (para una placa USB), o /dev/tty.USA19QW1b1P1.1 (para una placa serie conectada con un adaptador Keyspan de USB a serie). En Windows, son generalmente COM1 o COM2 (para placas serie) o COM4, COM5, COM7, y superiores (para una placa USB) - para encontrar un puerto, puedes mirar el dispositivo serie USB en la sección puertos del gestor de dispositivos de Windows. En Linux, suelen ser /dev/ttyUSB0, /dev/ttyUSB1 o similar.

Una vez hayas seleccionado la placa y el puerto correctos, pulsa el botón upload de la barra de herramientas o seleccióna el submenú Upload to I/O Board del menú File. Las placas Arduino más recientes se resetean automáticamente y comienza la grabación del sketch en el microcontrolador. En placas antiguas que no disponen de auto-reset tienes que pulsar el botón de reset de la placa justo antes de comenzar la grabación. En la mayoría de las placas, puedes ver como se iluminan los LEDs RX y TX mientras se graba el sketch en el microcontrolador. El entorno de desarrollo de Arduino muestra un mensaje cuando grabación ha finalizado correctamente o muestra el error que se haya producido.

Cuando almacenas tu sketch en el microcontrolador, estás usando el cargador de arranque (bootloader), un pequeño programa que ha sido grabado en el microcontrolador de tu placa. Él permite que tu grabes tu código sin necesidad de hardware adicional. El cargador de arranque está activo unos segundos cuando reinicias (reset) la placa; entonces comienza a ejecutar el último sketch que se haya almacenado en el microcontrolador. El cargador de arranque hace parpadear al LED (pin 13) de la placa cuando se ejecuta (p. ej. cuando la placa se reinicia).

Librerías

Las librerías proveen funcionalidades extra para que las uses en tus sketches, p.ej. para trabajar con determinado hardware o manipular información. Para usar una librería en tu sketch, escógela en el menú Sketch > Import Library. Esto insertará una o más órdenes #include al principio del código del sketch y compilará la librería junto con tu sketch. Como las librerías son grabadas en el microcontrolador de tu placa junto con tu sketch, se incrementa también el espacio usado en la memoria para programas del microcontrolador. Si tu sketch ya no necesita una librería, simplemente elimina sus órdenes #include del principio tu código.

Hay un listado de librerías en la guía de referencia. Algunas librerías vienen incluidas con el software de Arduino. Otras las puedes descargar de un montón de sitios. Para instalarte librerías de terceros, crea una carpeta llamada libraries dentro de la carpeta de tu cuaderno de sketches. Descomprime la librería en esa carpeta. Por ejemplo, para instalar la librería DateTime, sus archivos deben estár en la subcarpeta /libraries/DateTime de la carpeta de tu cuaderno de '¡sketches''.

Hardware de terceras partes.

Aunque el software de Arduino viene con únicamente con soporte para hardware oficial de Arduino, puedes instalar soporte por separado para otro hardware. Descárgate el contenido de la carpeta que contiene los archivos de otra plataforma y colócalos en la subcarpeta hardware de la carpeta de tu cuaderno de sketches. Una vez reinicies el software de Arduino, las placas de la plataforma deberán aparecer en el menú Tools > Boards. Elige la placa apropiada para compilar y grabar en tus sketches en esa placa (o para grabar cargadores de arranque en ella).

Monitor Serie

Muestra la información serie que se va recibiendo de la placa Arduino (placa USB o serie). Para enviar información (datos) a la placa, introduce texto y pincha con el ratón sobre el botón "send" o pulsa la tecla "enter". Elige la velocidad de transmisión de la caja desplegable que deberá coindicir con la velocidad de transmisión que has pasado a Serial.begin en tu sketch. Date cuenta que en Mac o Linux, la placa Arduino se reinicia (vuelve a ejecutar el sketch desde el principio) cuando te conectas con el monitor serie.

También puedes comunicarte con la placa desde Processing, Flash, MaxMSP, etcétera (Écha un vistazo a la página de interacción para más detalles).

Preferencias

Alguans preferencias las puedes configurar desde la ventana de diálogo Preferences (que se encuentra al final del menú Arduino en los Mac, o del menú File en Windows y Linux). El resto de las preferencias las podrás encontrar en el archivo preferences cuya ubicación se muestra en la ventana de diálogo Preference.

Placas

La selección de la placa tiene dos efectos: los parámetros (como la velocidad de la CPU y la velocidad de transmisión) usadas cuando compilas y grabas los sketches; y el archivo y configuración de los 'fuses' utilizados por el comando de grabación del cargador de arranque en el programa. Algunas definiciones de placas se diferencian solamente en lo último, por eso aunque hayas grabado sketches correctamente con una selección determinada quizás debas comprobarla antes de grabar el gestor de arranque.

  • Arduino Duemilanove or Nano w/ ATmega328
    Un ATmega328 trabajando a 16 MHz con auto-reset. También utilizado para las versiones de 16 MHz (5V) del Arduino Pro o del Pro Mini con microcontrolador ATmega328.

  • Arduino Diecimila, Duemilanove, or Nano w/ ATmega168
    Un microcontrolador ATmega168 trabajando a 16 MHz con auto-reset. La compilación y la grabación de los sketches es equivalente al Arduino NG o anterior con ATmega168, pero el cargador de arranque grabado tiene un tiempo de espera más rápido (y el LED del pin 13 luce una única vez en el reset). También se utiliza para las versiones de 16 MHz (5V) de Arduino Pro y Pro Mini con un ATmega168.

  • Arduino Mega
    Un microcontrolador ATmega1280 trabajando a 16 MHz con auto-reset.

  • Arduino Mini
    Es equivalente al Arduino NG o más antiguo con ATmega168 (p.ej. un ATmega168 trabajando a 16 MHz sin auto-reset).

  • Arduino BT
    Un microcontrolador ATmega168 trabajando a 16 MHz. El cargado de arranque grabado en el microcontrolador incluye código para inicializar el módulo de bluetooth que tiene incorporado.

  • LilyPad Arduino w/ ATmega328
    Un microcontrolador ATmega328 trabajando a 8 MHz (3.3V) con auto-reset. Es equivalente al Arduino Pro o al Pro Mini (3.3V, 8 MHz) con un ATmega328.

  • LilyPad Arduino w/ ATmega168
    Un microcontrolador ATmega168 trabajando a 8 MHz. La compilación y la grabación de sketches son equivalentes al Arduino Pro o al Pro Mini (8 MHz) con un ATmega168. Sin embargo el cargador de arranque grabado en el microcontrolador tiene un tiempo de espera más lento (y el LED del pin 13 luce tres veces cuando haces reset) porque las versiones originales de LilyPad no soportan auto-reset. Tampoco incluyen un reloj externo, por lo el comando de grabar el gestor de arranque configura los fuses del ATmega168 para un reloj interno de 8 MHz.

    Si tienes una versión reciente del LilyPad, (con un conector de programación de 6 pines), quizás prefieras seleccionar Arduino Pro o Mini (8 MHz) con ATmega168 antes de grabar el gestor de arranque.

  • Arduino Pro or Pro Mini (3.3V, 8 MHz) w/ ATmega328
    Un microcontrolador ATmega328 trabajando a 8 MHz (3.3V) con auto-reset. Es equivalente al Arduino LilyPad con un microcontrolador ATmega328.

  • Arduino Pro or Pro Mini (3.3V, 8 MHz) w/ ATmega168
    Un microcontrolador ATmega168 trabajando a 8 MHz (3.3V) con auto-reset.

  • Arduino NG or older w/ ATmega168
    Un microcontrolador ATmega168 trabajando a 16 MHz sin auto-reset. La compilación y la grabación de un sketch es equivalente al Arduino Diecimila o al Duemilanove con un ATmega168, pero el cargador de arranque grabado en el microcontrolador tiene un tiempo de espera más lento (el LED del pin 13 se ilumina tres veces al hacer reset).

  • Arduino NG or older w/ ATmega8
    Un microcontrolador ATmega8 trabajando a 16 MHz sin auto-reset.

Los textos de la guía "Como empezar con Arduino" están licenciados bajo Creative Commons Attribution-ShareAlike 3.0 License. El código fuente de los ejemplos en la guía están liberados como dominio público.

Share