(redirected from Tutorial.Bootloader)

Entorno de Desarrollo para Arduino

El entorno de Desarrollo Arduino está constituido por un editor de texto para escribir el código, un área de mensajes, una consola de texto, una barra de herramientas con botones para las funciones comunes, y una serie de menús. Permite la conexión con el hardware de Arduino para cargar los programas y comunicarse con ellos.

Arduino utiliza para escribir el software lo que denomina "sketch" (programa). Estos programas son escritos en el editor de texto. Existe la posibilidad de cortar/pegar y buscar/remplazar texto. En el área de mensajes se muestra información mientras se cargan los programas y también muestra errores. La consola muestra el texto de salida para el entorno de Arduino incluyendo los mensajes de error completos y otras informaciones. La barra de herramientas permite verificar el proceso de carga, creación, apertura y guardado de programas, y la monitorización serie:

Verify/Compile
Chequea el código en busca de errores.

Stop
Finaliza la monitorización serie y oculta otros botones

New
Crea un nuevo sketch.

Open
Presenta un menú de todos los programas sketch de su "sketchbook", (librería de sketch) . Un click sobre uno de ellos lo abrirá en la ventana actual.

Nota: Debido a un error bug en Java, la barra de desplazamiento scroll no funciona en este menú; si necesita abrir un programa que no se vea en la lista, utilice File | Sketchbook en el menú.

Save
Salva el programa sketch.

Upload to I/O Board
Compila el código y lo vuelca en la placa E/S de Arduino. Ver Volcado más detalles abajo.

Serial Monitor
Inicia la monitorización serie Monitorización Serie.

Encontrará otros comandos en los cinco menús: File, Edit, Sketch, Tools, Help. Los menús son sensibles al contexto, lo que significa que estarán disponibles sólo los elementos relevantes para la tarea que este realizando en ese momento.

Edit

  • Copy for Discourse
    Copia el código de su sketch en el portapapeles para con el formato adecuado para publicarlo en un foro, incluyendo la sintaxis coloreada.

  • Copy as HTML
    Copia el código de un programa(sketch) al portapapeles en formato HTML, adecuándolo para incrustarlo en una página web.

Sketch

  • Verify/Compile
    Verifica los errores de su programa (sketch)

  • Import Library
    Añade una librería a su programa(sketch) insertando la sentencia #include en el código. Para más detalles ver Librerías más abajo.

  • Show Sketch Folder
    Abre la carpeta de programas (sketch) en el escritorio.

  • Add File...
    Añade un fichero fuente al programa (se incluirá desde su ubicación actual). El fichero aparece en una nueva pestaña en la ventana del programa. Los ficheros pueden ser quitados del programa (sketch) utilizando el menú "tab".

Tools

  • Auto Format
    Da formato al código proporcionando estética: por ejemplo realiza tabulaciones entre la apertura y cierre de llaves, y las sentencias que tengan que ser tabuladas lo estarán.

  • Board
    Selecciona la placa que estás usuando. Ver más abajo Descripción de las placas.

  • Serial Port
    Este menú contiene todos los dispositivos serie (reales o virtuales) de su equipo. Se refrescará automáticamente cada vez que abras el menú tools.

  • Burn Bootloader
    Este elemento del menú le permite grabar un gestor de arranque (bootloader) dentro del microcontrolador de la placa Arduinio. Aunque no es un requisito para el normal funcionamiento de la placa Arduino, le será útil si compra un nuevo ATmega (el cual viene normalmente sin gestor de arranque). Asegúrese que ha seleccionado la placa correcta en el menú Boards antes de grabar el bootloader. Cuando use AVR ISP, tendrá que seleccionar en el menú Serial Port el puerto correspondiente.

Sketchbook (Librería de Sketch)

El entorno de Arduino incluye el concepto de "sketchbook": que es el lugar estándar para el almacenamiento de sus programas (o "sketch"). Los "sketches" dentro de su "sketchbook" pueden abrirse desde el menú File > Sketchbook o desde el botón de la barra de herramientas Open. La primera vez que arranque el software Arduino, se creará un directorio para su "sketchbook". Puede visualizar o cambiar su localización dentro de "sketchbook location" desde el apartado Preferences

Tabs, Multiple Files, and Compilation (Pestañas, Ficheros múltiples y compilación)

Permite manejar "sketches" con más de un fichero (cada uno de los cuales aparece en su pestaña). Pueden ser normalmente ficheros de código Arduino (no extensiones), ficheros C (extensiones .c), ficheros c++ (.cpp), o ficheros de cabecera (.h)

Uploading (Volcado)

Antes de volcar su "sketch", necesitaa seleccionar los elementos correspondientes desde los menús Tools > Board y Tools > Serial Port. Las boards (placas) están descritas abajo. En los Mac, el puerto serie será probablemente algo como /dev/tty.usbserial-1B1 (para una placa USB), o /dev/tty.USA19QW1b1P1.1 (para una placa serie conectada con un adaptador Keyspan USB-to-Serial). En Windows, probablemente sea COM1 o COM2 (para una placa serie) o COM4, COM5, COM7, o superior (para una placa USB)- para encontrarlos, debes buscar los dispositivos serie USB en la sección de puertos del Administrador de Dispositivos de Windows. En Linux, debería ser /dev/ttyUSB0, /dev/ttyUSB1 o similar.

Una vez que ha seleccionado el puerto serie y la placa, presione el botón de volcado en la barra de harramientas o selecione Upload to I/O Board desde el menú File. Las actuales placas de Arduino se resetearán automáticmamente y comenzará el volcado. Como las placas antiguas carecen de auto-reset, necesitará presionar el botón de reset en la placa, justo antes de iniciar el volcado. En muchas placas verá el led RX y TX parpadeando cuando el "sketch" está actualizándose. El entorno de Arduino mostrará un mensaje cuando el volcado esté completado, o mostrará un error.

Cuando se vuelca un "sketch", está utilizando el "bootloader" de Arduino, un pequeño programa que ha sido cargado en el microcontrolador en su placa. Permite el volcado del código sin utilizar hardware adicional. El "bootloader" está activo durante unos segundos cuando la placa es reseteada; después se incia el "sketch" que más recientemente se hubiera actualizado en el microcontrolador. El "bootloader" produce un parpadeo en el LED de la placa (pin 13) cuando se inicia (p.e. cuando las placas son reseteadas)

Libraries (Librerías)

Las librerías proporcionan funcionalidad extra para la utilización en "sketches", por ejemplo para trabajar con hardware o manipular datos. Para utilizar una librería en un "sketch", seleccione el menú Sketch > Import Library. Esto insertará una o más sentencias #include al principio del "sketch" y compilará la librería con su "sketch". Debido a que las librerías se vuelcan a la placa junto con su "sketch", incrementan la ocupación del espacio disponible. Si un "sketch" no precisa de una libreria, simplemente borra su sentencia #include en la parte inicial de su código.

Existe una Lista de librerías en las referencias. Algunas librerias estan incluidas en el software Arduino, otras pueden ser descargadas desde una gran variedad de fuentes. Para instalar estas librerías de terceros, crea un directorio denominado libraries en su Directorio sketchbook. Después descomprime la librería allí. Por ejemplo, para instalar la librería Data Time, sus ficheros deberían estar en una subcarpeta /libraries/DateTime en su carpeta de sketchbook.

Para escribir su propia librería, revisa este tutorial

Third-Party Hardware (Hardware de terceros)

Se puede agregar soporte para hardware de terceros en el directorio hardware del directorio "sketchbook". Las plataformas instaladas aquí pueden incluir la definición de las placas (que aparecen en el menú board), librerías del núcleo, "bootloaders", y definiciones de programador. Para instalarla, cree un directorio hardware, y en él descomprima la plataforma de terceros con su directorio. (No utilices "arduino" como nombre del subdirectorio o sobreescribirás la plataforma Arduino). Para desinstalarlo, simplemente borre ese directorio.

Para más detalles sobre la creación de paquetes de hardware de terceros visita Páginas de Plataformas en la web de Google Code developers.

Serial Monitor (Monitor Serie)

Muestra los datos enviados desde la placa Arduino (placa USB o serie). Para enviar datos a la placa, teclee el texto y pulsa el botón "send" o enter. Seleccione la velocidad (baud rate) en el menú desplegable que coincida con el configurado en Serial.begin dentro de su "sketch". Advertir que en Mac o Linux, la placa Arduino se resetea (su "sketch" es reiniciado desde el principio) cuando conecta con el monitor serie.

Se puede también comunicar con la placa desde Processing, Flash, MaxMSP, etc (ver Web de interface ('interfacing page') para más detalles)

Preferences (Preferencias)

Pueden configurarse otras preferencias en el apartado preference (lo podrás encontrar bajo el menú Arduino para los Mac, o en File para Windows y Linux). El resto de opciones puede ser localizado en el fichero de preferencias, que se podrá encontrar dentro del mismo apartado preference.

Boards (Placas)

La selección de placa tiene dos efectos: los parámetros utilizados cuando compila(por ejemplo, CPU usada y velocidad (baud rate)) y vuelcan los "sketches"; y el fichero y configuración utilizados por el gestor de arranque (bootloader)) al ser cargado. Algunas de las definiciones de las placas difieren sólo en lo segundo, incluso si ha sido cargado satisfactoriamente con una particular selección, usted podrá comprobarlo antes de grabar el "bootloader"

  • Arduino Duemilanove o Nano w/ ATmega328
    Un ATmega328 trabajando a 16MHz con auto-reset. También usado para las versiones 16 MHz (5V) de los Arduino Pro o Pro Mini con ATmega328.

  • Arduino Diecimila, Duemilanove, o Nano w/ ATmega168
    Un ATmega168 trabajando a 16MHz con auto-reset. En cuanto a la compilación y volcado es equivalente al Arduino NG o el más antiguo w/ATmega168, pero el "bootloader" tiene un timeout rápido (el LED en el pin 13 parpace sólo en el reset).También usa las versiones 16 MHz (5V) de los Arduino Pro y Pro Mini con ATmega168.

  • Arduino Mega
    Un ATmega1280 trabajando a 16MHz con auto-reset.

  • Arduino Mini
    Equivalente al Ardunio NG o el más antiguo w/ATmega168 (por ejemplo un ATmega168 trabajando a 16MHz sin auto-reset)

  • Arduino BT
    ATmega168 trabajando a 16MHz. El bootloader incluye código para iniciar el módulo bluetooth de la placa.

  • LilyPad Arduino w/ ATmega328
    Un ATmega328 trabajando a 8MHz (3.3V) con autor-reset. Equivalente al Arduino Pro o Pro Mini (3.3V 8 MHz) w/ATmega328.

  • LilyPad Arduino w/ ATmega168
    Un ATmega168 trabajando a 8MHz. En cuanto a la compilación y volcado es equivalente a Arduino Pro o Pro Mini (8MHz) w/ARmega168. El "bootloader", sin embargo, tiene un lento timeout (el LED 13 parpadea 3 veces y realiza el reset) debido a que la versión original del LilyPad no soporta auto-reset. Tampoco incluyen un reloj externo, por lo que el boottloader se ha cargado comfigurando los fuses del ATmega168 con el reloj interno de 8MHz.

    Si tenes una versión actual del LilyPad, (con un conector de programación de 6 pines) tendrás que seleccionar Arduino Pro o Pro Mini (8MHz) con ATmega168 antes de grabar el "bootloader"

  • Arduino Pro or Pro Mini (3.3V, 8 MHz) w/ ATmega328
    Un ATmega328 trabajando a 8MHz (3.3V) con auto-reset. Equivalente a LilyPad Arduino w/ ATmega328.

  • Arduino Pro or Pro Mini (3.3V, 8 MHz) w/ ATmega168
    Un ATmega168 trabajando a 8 MHz (3.3V) con auto-reset.

  • Arduino NG or older w/ ATmega168
    Un ATmega168 trabajando 16MHz sin auto-reset. En cuanto a la Compilación y volcado es equivalente al Arduino Diecimila o Duemilanove w/ATmega168, pero el grabado del "bootloader" es más lento (el LED 13 parpadea 3 veces y realiza el reset)

  • Arduino NG or older w/ ATmega8
    Un ATmega8 trabajando en 16MHz sin auto-reset

Los textos de la guía "Como empezar con Arduino" están licenciados bajo Creative Commons Attribution-ShareAlike 3.0 License. El código fuente de los ejemplos en la guía están liberados como dominio público.

Share